一、模板

const int MAX = 1000010;
int c[MAX] = {0};
int lowbit(const int& x){ return (x)&(-x); }
void zero() { memset(c, 0, sizeof(c)); }
// 一定要小心零的问题
void modify(int i, const int& d)
{
    while (i <= MAX)
    {
        c[i] += d;
        i += lowbit(i);
    }
}
int sum(int i)
{
    int ret = 0;
    while (i) {
        ret += c[i];
        i -= lowbit(i);
    }
    return ret;
}

二、例题(POJ2352

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Solution

#define _CRT_SECURE_NO_WARNINGS
#include "cstdio"
#include "iostream"
#include "algorithm"
#include "cstring"

using namespace std;
const int MAX = 1000010;
int c[MAX] = {0};
int lowbit(const int& x){ return (x)&(-x); }
void zero() { memset(c, 0, sizeof(c)); }
// 一定要小心零的问题
void modify(int i, const int& d)
{
    while (i <= MAX)
    {
        c[i] += d;
        i += lowbit(i);
    }
}
int sum(int i)
{
    int ret = 0;
    while (i) {
        ret += c[i];
        i -= lowbit(i);
    }
    return ret;
}

int R[MAX] = { 0 };
int main()
{
    int N,x,y;
    scanf("%d",&N);
    for (int i = 0; i < N; ++i) {
        scanf("%d%d", &x, &y); ++x;
        ++R[sum(x)];
        modify(x, 1);
    }
    for (int i = 0; i < N; ++i) {
        printf("%d\n",R[i]);
    }
    return 0;
}