一、模板

int P[maxn] = {};
int F(int i){return P[i] == i ? i : P[i] = F(P[i]);}

二、例题(HDU1856

Description:

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.
Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2

Solution

#define _CRT_SECURE_NO_WARNINGS
#include "iostream"
#include "algorithm"
using namespace std;
const int maxn = 10000010;
int P[maxn] = {};
int N[maxn] = {};
int F(int i){return P[i] == i ? i : P[i] = F(P[i]);}
int main()
{
    int n,a,b,m;
    while ((scanf("%d", &n) == 1 )&& (m = 1)){
        for (int i = 0; i < maxn; ++i) P[i] = i, N[i] = 1;
        for (int i = 0; i < n; ++i){
            scanf("%d%d", &a, &b);
            int x = F(a), y = F(b);
            if (x != y) { P[x] = y, N[y] += N[x]; if (m < N[y]) m = N[y]; }
        }
        printf("%d\n", m);
    }
    return 0;
}